summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mail.scm21
1 files changed, 17 insertions, 4 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 81dc5b8eec..7fd3170af5 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2014, 2015, 2017 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015, 2017, 2020 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
;;; Copyright © 2014 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2014, 2019 Julien Lepiller <julien@lepiller.eu>
@@ -926,14 +926,20 @@ invoking @command{notifymuch} from the post-new hook.")
(define-public notmuch
(package
(name "notmuch")
- (version "0.29.3")
+ (version "0.30-0.31rc1") ; Ensure it is ordered before "0.31"
(source (origin
(method url-fetch)
(uri (string-append "https://notmuchmail.org/releases/notmuch-"
- version ".tar.xz"))
+ ;; version
+ "0.31~rc1" ;FIXME: Remove on the next update
+ ".tar.xz"))
+ ;; FIXME: The 'file-name' field below is needed only because of
+ ;; the tilde "~" in the URL base name. Remove it when the tilde
+ ;; is no longer there.
+ (file-name (string-append name "-" version ".tar.xz"))
(sha256
(base32
- "0dfwa38vgnxk9cvvpza66szjgp8lir6iz6yy0cry9593lywh9xym"))))
+ "11f10r9pp3p22afpfsrlz0xa0raas4w7fg2jkscgkjj5710ws8fw"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((guix build gnu-build-system)
@@ -963,6 +969,13 @@ invoking @command{notifymuch} from the post-new hook.")
(string-append "--prefix=" out)
(string-append "--emacslispdir=" elisp)
(string-append "--emacsetcdir=" elisp)))))
+ (add-before 'check 'disable-failing-tests
+ ;; FIXME: Investigate why these tests are failing,
+ ;; and try removing this for notmuch versions >= 0.31.
+ (lambda _
+ (substitute* "test/T356-protected-headers.sh"
+ (("\\$NOTMUCH_GMIME_X509_CERT_VALIDITY") "0"))
+ #t))
(add-before 'check 'prepare-test-environment
(lambda _
(setenv "TEST_CC" "gcc")