summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 080d3fccc9..ceb4896d34 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2068,10 +2068,18 @@ from git information.
(base32
"0djxvdwm8s60dbfn7bhf40x6g818p3b3mlwijm1c3bqg7msn271y"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (zero? (system* "python" "-m" "testtools.run"
+ "fixtures.test_suite")))))))
(propagated-inputs
`(("python-six" ,python-six)))
(native-inputs
- `(("python-pbr-minimal" ,python-pbr-minimal)
+ `(("python-mock" ,python-mock)
+ ("python-pbr-minimal" ,python-pbr-minimal)
("python-testtools" ,python-testtools)))
(home-page "https://launchpad.net/python-fixtures")
(synopsis "Python test fixture library")