summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-jll.scm39
-rw-r--r--gnu/packages/julia-xyz.scm39
2 files changed, 39 insertions, 39 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index a403829ff2..9d6d692f8a 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -25,6 +25,7 @@
#:use-module (guix utils)
#:use-module (guix build-system julia)
#:use-module (gnu packages)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages gcc)
#:use-module (gnu packages image)
#:use-module (gnu packages julia)
@@ -279,3 +280,41 @@ autogenerated source package constructed using @code{BinaryBuilder.jl}. The
originating @code{build_tarballs.jl} script can be found on the community
build tree Yggdrasil.")
(license license:expat))))
+
+(define-public julia-zlib-jll
+ (package
+ (name "julia-zlib-jll")
+ (version "1.2.12+1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/Zlib_jll.jl")
+ (commit (string-append "Zlib-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05ih0haqapkzr40swvq63cafnqlc4yp6yfa1wvdyq8v3n4kxhfqa"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("generate_wrapper_header.*")
+ (string-append
+ "generate_wrapper_header(\"Zlib\", \""
+ (assoc-ref inputs "zlib") "\")\n"))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("zlib" ,zlib)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)))
+ (home-page "https://github.com/JuliaBinaryWrappers/Zlib_jll.jl")
+ (synopsis "Zlib library wrappers")
+ (description "This package provides a wrapper for Zlib.")
+ (license license:expat)))
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 86cb2933f7..3eabf7a5ad 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1772,45 +1772,6 @@ useful in order to support @code{VersionNumber} comparisons applied to
archives in Julia.")
(license license:expat)))
-(define-public julia-zlib-jll
- (package
- (name "julia-zlib-jll")
- (version "1.2.12+1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/JuliaBinaryWrappers/Zlib_jll.jl")
- (commit (string-append "Zlib-v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "05ih0haqapkzr40swvq63cafnqlc4yp6yfa1wvdyq8v3n4kxhfqa"))))
- (build-system julia-build-system)
- (arguments
- '(#:tests? #f ; no runtests
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
- (lambda* (#:key inputs #:allow-other-keys)
- (map
- (lambda (wrapper)
- (substitute* wrapper
- (("generate_wrapper_header.*")
- (string-append
- "generate_wrapper_header(\"Zlib\", \""
- (assoc-ref inputs "zlib") "\")\n"))))
- ;; There's a Julia file for each platform, override them all
- (find-files "src/wrappers/" "\\.jl$")))))))
- (inputs
- `(("zlib" ,zlib)))
- (propagated-inputs
- `(("julia-jllwrappers" ,julia-jllwrappers)))
- (home-page "https://github.com/JuliaBinaryWrappers/Zlib_jll.jl")
- (synopsis "Zlib library wrappers")
- (description "This package provides a wrapper for Zlib.")
- (license license:expat)))
-
(define-public julia-zstd-jll
(package
(name "julia-zstd-jll")