summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..3202b91
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,17 @@
+SUBDIRS = lib
+ACLOCAL_AMFLAGS = -I m4
+EXTRA_DIST = m4/gnulib-cache.m4 \
+ $(top_srcdir)/.version
+
+MAINTAINERCLEANFILES = .version
+BUILT_SOURCES = $(top_srcdir)/.version
+
+$(top_srcdir)/.version:
+ $(AM_V_GEN) echo '$(VERSION)' > $@-t
+ @mv $@-t $@
+
+dist-hook:
+ echo '$(VERSION)' > $(distdir)/.tarball-version
+
+include %D%/src/Makefile.am
+include %D%/json-elements/Makefile.am