summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac37
1 files changed, 37 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..224342c
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,37 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ([2.71])
+AC_INIT([neoas], m4_esyscmd([sh build-aux/git-version-gen .tarball-version]), [vivien@planete-kraus.eu])
+AC_CONFIG_SRCDIR([src/json-lexer.c])
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_AUX_DIR([build-aux])
+
+# Checks for programs.
+AC_PROG_CC
+gl_EARLY
+AM_INIT_AUTOMAKE([subdir-objects])
+
+gl_INIT
+
+# Checks for libraries.
+AC_SEARCH_LIBS([pow], [m])
+
+# Checks for header files.
+AC_CHECK_HEADERS([math.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_C_INLINE
+AC_TYPE_UINT8_T
+AC_C_RESTRICT
+AC_TYPE_SIZE_T
+AC_TYPE_SSIZE_T
+
+# Checks for library functions.
+AC_FUNC_MALLOC
+AC_FUNC_REALLOC
+AC_CHECK_FUNCS([calloc pow])
+
+AC_CONFIG_FILES([Makefile
+ lib/Makefile])
+AC_OUTPUT