summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2024-01-17 23:55:17 +0100
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2024-03-03 22:03:21 +0100
commit843e2d7d8d790a02035e90f34928b5c8840c6b9e (patch)
treea21d7079710e914138193912a0fb2487e32e4aac /Makefile
parent25bcda2b9107b948a1c858e41aba1b7f95b76228 (diff)
Add git hook for checking commit signing.make-authenticate
This is analogue to what upstream Guix does in order to prevent invalid signed commits being pushed. * Makefile: New file. * etc/git/pre-push: New file. Co-authored-by: Wolf <wolf@wolfsden.cz>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..e5f968b
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,14 @@
+# SPDX-License-Identifier: GPL-3.0-or-later
+# Copyright © 2022 Giacomo Leidi <goodoldpaul@autistici.org>
+# Copyright © 2024 Jonathan Brielmaier <jonathan.brielmaier@web.de>
+# Copyright © 2024 Wolf <wolf@wolfsden.cz>
+
+# nonguix channel
+channel_intro_commit = 897c1a470da759236cc11798f4e0a5f7d4d59fbc
+channel_intro_signer = 2A39 3FFF 68F4 EF7A 3D29 12AF 6F51 20A0 22FB B2D5
+
+authenticate:
+ echo "Authenticating Git checkout..." ; \
+ guix git authenticate \
+ --cache-key=channels/nonguix --stats \
+ "$(channel_intro_commit)" "$(channel_intro_signer)"