summaryrefslogtreecommitdiff
path: root/nongnu/packages/lisp.scm
diff options
context:
space:
mode:
authorAndre A. Gomes <andremegafone@gmail.com>2023-07-20 20:02:13 +0300
committerPierre Neidhardt <mail@ambrevar.xyz>2023-07-21 13:47:46 +0200
commitd96252ee34c66f3fcbed189f6ee10e52788761e3 (patch)
tree1ede1f58060460df4c1101705e0c767f4308facc /nongnu/packages/lisp.scm
parent26a0ea1a7d811f333a4387b6871257435840aba6 (diff)
gnu: sbcl-cl-electron: Update to 0.0.0-1.ec8e361.
* nongnu/packages/lisp.scm (sbcl-cl-electron): Update to 0.0.0-1.ec8e361. Signed-off-by: Pierre Neidhardt <mail@ambrevar.xyz>
Diffstat (limited to 'nongnu/packages/lisp.scm')
-rw-r--r--nongnu/packages/lisp.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/nongnu/packages/lisp.scm b/nongnu/packages/lisp.scm
index 5607cda..da3a1e8 100644
--- a/nongnu/packages/lisp.scm
+++ b/nongnu/packages/lisp.scm
@@ -125,8 +125,8 @@ then open a browser at http://localhost:PORT, where PORT is the indicated port."
"https://franz.com/ftp/pub/legal/ACL-Express-20170301.pdf"))))
(define-public sbcl-cl-electron
- (let ((commit "f2b8615ec398c88a35c2d4e01dc41381e1e59586")
- (revision "0"))
+ (let ((commit "ec8e3610be26d2d7312fab7d59d840e550b221f2")
+ (revision "1"))
(package
(name "sbcl-cl-electron")
(version (git-version "0.0.0" revision commit))
@@ -138,12 +138,13 @@ then open a browser at http://localhost:PORT, where PORT is the indicated port."
(commit commit)))
(file-name (git-file-name "cl-electron" version))
(sha256
- (base32 "081gcfr8cn9cdyqh81pcks6s7nfmhwy5a5s8xq9k3kx61w5mk2b2"))))
+ (base32 "0bmnh0xl5pvjv4pdb4a37x87zlyzr5fy7cyaws69p4p4rgzszzv8"))))
(build-system asdf-build-system/sbcl)
(native-inputs (list ;; sbcl-lisp-unit2
sbcl))
(inputs (list electron node
- sbcl-cl-json sbcl-usocket sbcl-parenscript sbcl-bordeaux-threads))
+ sbcl-cl-json sbcl-iolib sbcl-nclasses
+ sbcl-parenscript sbcl-bordeaux-threads))
(synopsis "Common Lisp interface to Electron")
(home-page "https://github.com/atlas-engineer/cl-electron")
(description "@command{cl-electron} is a binding to Electron for