summaryrefslogtreecommitdiff
path: root/nongnu/packages
diff options
context:
space:
mode:
authorTomas Volf <~@wolfsden.cz>2024-03-19 15:52:50 +0100
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2024-03-21 12:28:57 +0100
commitcd6b8abeb3f99ceb6a671cafbfbdf0d618ec984b (patch)
treefbaa61a392f4a2b0f86b40864318cbf5c61cb8b3 /nongnu/packages
parent545a11dee6d522648374a1de144bfb40031c5623 (diff)
nongnu: firefox-esr: Update to 115.9.0esr [security fixes].
Fixes CVE-2023-5388, CVE-2024-0743, CVE-2024-2605, CVE-2024-2607, CVE-2024-2608, CVE-2024-2610, CVE-2024-2611, CVE-2024-2612, CVE-2024-2614, CVE-2024-2616. * nongnu/packages/mozilla.scm (firefox-esr): Update to 115.9.0esr. Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
Diffstat (limited to 'nongnu/packages')
-rw-r--r--nongnu/packages/mozilla.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/nongnu/packages/mozilla.scm b/nongnu/packages/mozilla.scm
index c9a4e6a..bc2b286 100644
--- a/nongnu/packages/mozilla.scm
+++ b/nongnu/packages/mozilla.scm
@@ -97,19 +97,19 @@
;; Update this id with every firefox update to its release date.
;; It's used for cache validation and therefore can lead to strange bugs.
-(define %firefox-esr-build-id "20240219101823")
+(define %firefox-esr-build-id "20240318135224")
(define-public firefox-esr
(package
(name "firefox-esr")
- (version "115.8.0esr")
+ (version "115.9.0esr")
(source
(origin
(method url-fetch)
(uri (string-append "https://archive.mozilla.org/pub/firefox/releases/"
version "/source/firefox-" version ".source.tar.xz"))
(sha256
- (base32 "1slmp2v1q3my81z8kiym9rpxw5d9n4sn07v7hv99517w7vr8d05g"))))
+ (base32 "00r847l2j2wk20wf1plbnz2ifyqkvwqmaqwq6zknsqz6qmqk6fyv"))))
(build-system gnu-build-system)
(arguments
(list