summaryrefslogtreecommitdiff
path: root/nongnu
diff options
context:
space:
mode:
authorTomas Volf <~@wolfsden.cz>2024-04-16 20:58:54 +0200
committerJohn Kehayias <john.kehayias@protonmail.com>2024-04-17 12:57:55 -0400
commit1ee5d0cc09155e81ce0255b81a212922dad10a17 (patch)
tree05b8bf03a3cc53538ab5ddc59436438b6dc168e0 /nongnu
parent22ceef25015d0ebeb23f9dfe6305b4e542fc6225 (diff)
nongnu: firefox: Update to 125.0.1 [security fixes].
Fixes CVE-2024-3302, CVE-2024-3852, CVE-2024-3853, CVE-2024-3854, CVE-2024-3855, CVE-2024-3856, CVE-2024-3857, CVE-2024-3858, CVE-2024-3859, CVE-2024-3860, CVE-2024-3861, CVE-2024-3862, CVE-2024-3863, CVE-2024-3864, CVE-2024-3865. * nongnu/packages/mozilla.scm (firefox): Update to 125.0.1. Signed-off-by: John Kehayias <john.kehayias@protonmail.com>
Diffstat (limited to 'nongnu')
-rw-r--r--nongnu/packages/mozilla.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/nongnu/packages/mozilla.scm b/nongnu/packages/mozilla.scm
index adf20d1..37a129f 100644
--- a/nongnu/packages/mozilla.scm
+++ b/nongnu/packages/mozilla.scm
@@ -532,20 +532,20 @@ MOZ_ENABLE_WAYLAND=1 exec ~a $@\n"
;; Update this id with every firefox update to its release date.
;; It's used for cache validation and therefore can lead to strange bugs.
-(define %firefox-build-id "20240401222156")
+(define %firefox-build-id "20240416141733")
(define-public firefox
(package
(inherit firefox-esr)
(name "firefox")
- (version "124.0.2")
+ (version "125.0.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://archive.mozilla.org/pub/firefox/releases/"
version "/source/firefox-" version ".source.tar.xz"))
(sha256
- (base32 "076rnbj1813b46slqp1pim3qkh9n0i4y8r3krdsqi77180snslm6"))))
+ (base32 "046d84j46qi51i1nc1ysmjma0br1sd5smhsnv3y066w1c3ng4kr7"))))
(arguments
(substitute-keyword-arguments (package-arguments firefox-esr)
((#:phases phases)