summaryrefslogtreecommitdiff
path: root/nongnu
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2022-04-05 22:31:38 +0200
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2022-04-05 22:31:38 +0200
commit3bc2fc2f8ba709deb5149c9ed06900233e3ca479 (patch)
tree22fdaa15d7106657c18b1c01e16c29b347db63d0 /nongnu
parentd3a550dbf2cd099a1e20ed5407c443e396b5d44b (diff)
nongnu: firefox: Update to 99.0 [security fixes].
Fixes CVE-2022-1097, CVE-2022-24713, CVE-2022-28281, CVE-2022-28282, CVE-2022-28283, CVE-2022-28285, CVE-2022-28286, CVE-2022-28287, CVE-2022-28288 and CVE-2022-28289. * nongnu/packages/mozilla.scm (firefox): Update to 99.0.
Diffstat (limited to 'nongnu')
-rw-r--r--nongnu/packages/mozilla.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/nongnu/packages/mozilla.scm b/nongnu/packages/mozilla.scm
index 7df2657..8ceeb5e 100644
--- a/nongnu/packages/mozilla.scm
+++ b/nongnu/packages/mozilla.scm
@@ -86,19 +86,19 @@
;; Update this id with every firefox update to it's release date.
;; It's used for cache validation and therefor can lead to strange bugs.
-(define %firefox-build-id "20220308000000")
+(define %firefox-build-id "20220405000000")
(define-public firefox
(package
(name "firefox")
- (version "98.0")
+ (version "99.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://archive.mozilla.org/pub/firefox/releases/"
version "/source/firefox-" version ".source.tar.xz"))
(sha256
- (base32 "1pglnq657vxz6ywlqhl8a6a24x4vkzwv0zk60rbh9n87s08lq2px"))))
+ (base32 "09v3jyby6j7sf08r8svhb9qrzs4kh325r8n4y982v6m3mwn8sgsi"))))
(build-system gnu-build-system)
(arguments
(list