summaryrefslogtreecommitdiff
path: root/nongnu
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2023-09-21 02:42:33 +0200
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2023-12-28 23:46:20 +0100
commit62d1c7ab6b2bda4d301e0f10d290d9250ac92d10 (patch)
treee72c467bce5e82ef011c2c5431cf2c7d7d6c7459 /nongnu
parent9a0253ae893aca6d3363bd5ad9158b4dc2fbfa98 (diff)
nongnu: lycheeslicer: Avoid manually unpacking .deb file.
* nongnu/packages/engineering.scm (lycheeslicer)[phases]<unpack>: Replace with 'setup-cwd; <symlink-binary-file>: there's no need anymore to care about the environment-variables file; [native-inputs]: drop tar. Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
Diffstat (limited to 'nongnu')
-rw-r--r--nongnu/packages/engineering.scm15
1 files changed, 4 insertions, 11 deletions
diff --git a/nongnu/packages/engineering.scm b/nongnu/packages/engineering.scm
index e4ddd5b..b05f6c0 100644
--- a/nongnu/packages/engineering.scm
+++ b/nongnu/packages/engineering.scm
@@ -35,28 +35,22 @@
#~'("lib/LycheeSlicer/lycheeslicer")
#:phases
#~(modify-phases %standard-phases
- (replace 'unpack
+ (add-after 'binary-unpack 'setup-cwd
(lambda _
- (invoke "ar" "x" #$source)
- (invoke "tar" "xvf" "data.tar.xz")
;; Use the more standard lib directory for everything.
(rename-file "opt/" "lib")
(mkdir-p "share")
(copy-recursively "usr/share" "share")
;; Remove unneeded files.
- (delete-file-recursively "usr")
- (delete-file "control.tar.gz")
- (delete-file "data.tar.xz")
- (delete-file "debian-binary")))
- (add-after 'unpack 'fix-desktop-file
+ (delete-file-recursively "usr")))
+ (add-after 'setup-cwd 'fix-desktop-file
(lambda _
;; Fix the .desktop file binary location.
(substitute* '("share/applications/lycheeslicer.desktop")
(("/opt/LycheeSlicer")
(string-append #$output "/lib/LycheeSlicer")))))
- (add-before 'install-wrapper 'symlink-binary-file-and-cleanup
+ (add-before 'install-wrapper 'symlink-binary-file
(lambda _
- (delete-file (string-append #$output "/environment-variables"))
(mkdir-p (string-append #$output "/bin"))
(symlink (string-append #$output "/lib/LycheeSlicer/lycheeslicer")
(string-append #$output "/bin/lycheeslicer"))))
@@ -68,7 +62,6 @@
(list
(string-append #$output "/lib/LycheeSlicer"))
":")))))))))
- (native-inputs (list tar))
(inputs
(list libxscrnsaver))
(home-page "https://mango3d.io")