summaryrefslogtreecommitdiff
path: root/nongnu
diff options
context:
space:
mode:
authorTomas Volf <~@wolfsden.cz>2023-12-19 17:25:47 +0100
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2023-12-21 12:37:27 +0100
commit75541ecc299ad884e1e9dc04e8d4a347bfe40cbf (patch)
tree05778fb8095f1f306e9f555042dfbe8128db60ce /nongnu
parent5d308347ca094d045dcc932540262f5f60c63eed (diff)
nongnu: firefox: Update to 121.0 [security fixes].
Fixes CVE-2023-6135, CVE-2023-6856, CVE-2023-6857, CVE-2023-6858, CVE-2023-6859, CVE-2023-6860, CVE-2023-6861, CVE-2023-6863, CVE-2023-6864, CVE-2023-6865, CVE-2023-6866, CVE-2023-6867, CVE-2023-6868, CVE-2023-6869, CVE-2023-6870, CVE-2023-6871, CVE-2023-6872, CVE-2023-6873. Firefox 121.0 uses Wayland now by default when available on Linux: https://www.mozilla.org/en-US/firefox/121.0/releasenotes/ * nongnu/packages/mozilla.scm (firefox): Update to 121.0. (firefox/wayland): Remove variable and deprecate the package. Co-authored-by: Ada Stevenson <adanskana@gmail.com> Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
Diffstat (limited to 'nongnu')
-rw-r--r--nongnu/packages/mozilla.scm44
1 files changed, 6 insertions, 38 deletions
diff --git a/nongnu/packages/mozilla.scm b/nongnu/packages/mozilla.scm
index 63d87e9..a207db2 100644
--- a/nongnu/packages/mozilla.scm
+++ b/nongnu/packages/mozilla.scm
@@ -532,20 +532,20 @@ MOZ_ENABLE_WAYLAND=1 exec ~a $@\n"
;; Update this id with every firefox update to its release date.
;; It's used for cache validation and therefore can lead to strange bugs.
-(define %firefox-build-id "20231129224408")
+(define %firefox-build-id "20231218153158")
(define-public firefox
(package
(inherit firefox-esr)
(name "firefox")
- (version "120.0.1")
+ (version "121.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://archive.mozilla.org/pub/firefox/releases/"
version "/source/firefox-" version ".source.tar.xz"))
(sha256
- (base32 "1qlsjpiwgr17bd0dphshs6dj23889m7h3sfq8j21b0282hmbprvn"))))
+ (base32 "193al259awzfi5c3pf8257p8qr9i4biapx9bw8ijmzr3klasbizd"))))
(arguments
(substitute-keyword-arguments (package-arguments firefox-esr)
((#:phases phases)
@@ -562,38 +562,6 @@ MOZ_ENABLE_WAYLAND=1 exec ~a $@\n"
"Full-featured browser client built from Firefox source tree, without
the official icon and the name \"firefox\".")))
-(define-public firefox/wayland
- (package
- (inherit firefox)
- (name "firefox-wayland")
- (native-inputs '())
- (inputs
- `(("bash" ,bash-minimal)
- ("firefox" ,firefox)))
- (build-system trivial-build-system)
- (arguments
- '(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let* ((bash (assoc-ref %build-inputs "bash"))
- (firefox (assoc-ref %build-inputs "firefox"))
- (out (assoc-ref %outputs "out"))
- (exe (string-append out "/bin/firefox")))
- (mkdir-p (dirname exe))
-
- (call-with-output-file exe
- (lambda (port)
- (format port "#!~a
-MOZ_ENABLE_WAYLAND=1 exec ~a $@\n"
- (string-append bash "/bin/bash")
- (string-append firefox "/bin/firefox"))))
- (chmod exe #o555)
-
- ;; Provide the manual and .desktop file.
- (copy-recursively (string-append firefox "/share")
- (string-append out "/share"))
- (substitute* (string-append
- out "/share/applications/firefox.desktop")
- ((firefox) out))
- #t))))))
+;; As of Firefox 121.0, Firefox uses Wayland by default. This means we no longer need a seperate package
+;; for Firefox on Wayland.
+(deprecated-package "firefox-wayland" firefox)