summaryrefslogtreecommitdiff
path: root/nongnu
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2023-12-29 00:47:13 +0100
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2023-12-29 00:47:13 +0100
commit8956906f6bed6709e71f0c26ed6a3620f40dc487 (patch)
tree540681f2f077c3c2017bc200567c0ffad79a894f /nongnu
parent0f355661044affec8532380fff6d5f027fbd899a (diff)
nongnu: libsteam: Fix build.
The new unpack-binary phase seems to not harmonize with patchelf always: https://gitlab.com/nonguix/nonguix/-/merge_requests/336#note_1709385147 * nongnu/packages/game-development.scm (libsteam)[arguments]: Delete 'binary-unpack for now.
Diffstat (limited to 'nongnu')
-rw-r--r--nongnu/packages/game-development.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/nongnu/packages/game-development.scm b/nongnu/packages/game-development.scm
index 566cea2..0e28127 100644
--- a/nongnu/packages/game-development.scm
+++ b/nongnu/packages/game-development.scm
@@ -144,6 +144,7 @@ development should opt for GLSL rather than Cg.")
(copy-file (assoc-ref inputs "source") "libsteam_api.so")
(chmod "libsteam_api.so" #o644)
#t))
+ (delete 'binary-unpack)
(add-after 'install 'symlink
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))