summaryrefslogtreecommitdiff
path: root/nongnu
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2023-09-21 02:29:00 +0200
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2023-12-28 23:42:33 +0100
commita33d57ee74638b675d3951279e731839d50ddc78 (patch)
treeac419f16b2c02cd4c5fc8f4b65564773086d71dd /nongnu
parent00e0b5f319d660298f9650f8e225e755fdf79e6d (diff)
nongnu: chrome: Avoid manually unpacking .deb file.
* nongnu/packages/chrome.scm (make-google-chrome)[phases] Drop 'unpack-deb phase; [native-inputs]: drop tar. Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
Diffstat (limited to 'nongnu')
-rw-r--r--nongnu/packages/chrome.scm11
1 files changed, 0 insertions, 11 deletions
diff --git a/nongnu/packages/chrome.scm b/nongnu/packages/chrome.scm
index 388b02c..16d7f89 100644
--- a/nongnu/packages/chrome.scm
+++ b/nongnu/packages/chrome.scm
@@ -72,16 +72,6 @@
("usr/share/" "/share"))
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'unpack-deb
- (lambda* (#:key inputs #:allow-other-keys)
- (invoke "ar" "x" #$source)
- (invoke "rm" "-v" "control.tar.xz"
- "debian-binary"
- (string-append "google-chrome-" #$repo "_"
- #$version
- "-1_amd64.deb"))
- (invoke "tar" "xf" "data.tar.xz")
- (invoke "rm" "-vrf" "data.tar.xz" "etc")))
(add-before 'install 'patch-assets
;; Many thanks to
;; https://github.com/NixOS/nixpkgs/blob/master/pkgs/applications/networking/browsers/google-chrome/default.nix
@@ -128,7 +118,6 @@
(symlink chrome-target exe)
(wrap-program exe
'("CHROME_WRAPPER" = (#$appname)))))))))
- (native-inputs (list tar))
(inputs
(list bzip2
curl