summaryrefslogtreecommitdiff
path: root/nonguix
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2023-12-29 22:23:03 +0100
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2024-01-04 23:19:53 +0100
commita328f6c91f3d24508ff37338e6a68ba82aaa0141 (patch)
tree6afbf57dd18eaa09fd3af9a7ea242232da5f0bf5 /nonguix
parent4f2dca39151066eb752a37b0bf583a33c4092341 (diff)
nonguix: binary: Cleanup when an unknown binary extension is detected.
The binary-unpack phase suffered from a problem for unknown binary file extensions, see: !336 (comment 1709385147) . This patch fixes the incorrect behavior by effectively restoring the state of the directory tree before the phase. * nonguix/build/binary-build-system.scm (binary-unpack): Restore the environment as it was before this phase. * nongnu/packages/clojure.scm (clj-kondo)[arguments]: No longer delete 'binary-unpack phase. * nongnu/packages/game-development.scm (libsteam)[arguments]: dito. Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
Diffstat (limited to 'nonguix')
-rw-r--r--nonguix/build/binary-build-system.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/nonguix/build/binary-build-system.scm b/nonguix/build/binary-build-system.scm
index 147aa18..e5bbc48 100644
--- a/nonguix/build/binary-build-system.scm
+++ b/nonguix/build/binary-build-system.scm
@@ -155,7 +155,12 @@ The inputs are optional when the file is an executable."
(chdir "binary")
(match binary-file
((? deb-file?) (unpack-deb binary-file))
- (_ (format #t "Unknown file type: ~a~%" (basename binary-file)))))))
+ (_
+ (begin
+ (format #t "Unknown file type: ~a~%" (basename binary-file))
+ ;; Cleanup after ourselves
+ (chdir "..")
+ (rmdir "binary")))))))
(define %standard-phases
;; Everything is as with the GNU Build System except for the `binary-unpack',