summaryrefslogtreecommitdiff
path: root/nongnu/packages/chromium.scm
diff options
context:
space:
mode:
Diffstat (limited to 'nongnu/packages/chromium.scm')
-rw-r--r--nongnu/packages/chromium.scm25
1 files changed, 5 insertions, 20 deletions
diff --git a/nongnu/packages/chromium.scm b/nongnu/packages/chromium.scm
index 56d0c6e..4467714 100644
--- a/nongnu/packages/chromium.scm
+++ b/nongnu/packages/chromium.scm
@@ -1,20 +1,5 @@
-;;; GNU Guix --- Functional package management for GNU
+;;; SPDX-License-Identifier: GPL-3.0-or-later
;;; Copyright © 2022 Pierre Neidhardt <mail@ambrevar.xyz>
-;;;
-;;; This file is not part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (nongnu packages chromium)
#:use-module ((guix licenses) #:prefix license:)
@@ -41,15 +26,15 @@
#:use-module (srfi srfi-1))
(define-public chromium-embedded-framework
- (let ((git-revision "d0bbcbb")
- (chromium-version "103.0.5060.114")
+ (let ((git-revision "5053a95")
+ (chromium-version "117.0.5938.150")
(arch (match (or (%current-target-system) (%current-system))
("aarch64-linux" "linuxarm64")
("armhf-linux" "linuxarm")
(_ "linux64"))))
(package
(name "chromium-embedded-framework")
- (version "103.0.9")
+ (version "117.2.4")
(source (origin
(method url-fetch)
(uri (string-append
@@ -60,7 +45,7 @@
"_" arch "_minimal.tar.bz2"))
(sha256
(base32
- "143x0jmasl4z16bkxlrbz874chd9x9xpc5qylb9h7j80gfcrzlsi"))))
+ "0vzzwq1k6bv9d209yg3samvfnfwj7s58y9r3p3pd98wxa9iyzf4j"))))
(build-system binary-build-system)
(arguments
`(#:patchelf-plan