summaryrefslogtreecommitdiff
path: root/nongnu/packages/gog.scm
diff options
context:
space:
mode:
Diffstat (limited to 'nongnu/packages/gog.scm')
-rw-r--r--nongnu/packages/gog.scm31
1 files changed, 10 insertions, 21 deletions
diff --git a/nongnu/packages/gog.scm b/nongnu/packages/gog.scm
index 391687d..f6deffb 100644
--- a/nongnu/packages/gog.scm
+++ b/nongnu/packages/gog.scm
@@ -1,18 +1,7 @@
+;;; SPDX-License-Identifier: GPL-3.0-or-later
;;; Copyright © 2019, 2020 Alex Griffin <a@ajgrf.com>
-;;; Copyright © 2021 Timotej Lazar <timotej.lazar@araneo.si>
-;;;
-;;; This program is free software: you can redistribute it and/or modify
-;;; it under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation, either version 3 of the License, or
-;;; (at your option) any later version.
-;;;
-;;; This program is distributed in the hope that it will be useful,
-;;; but WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with this program. If not, see <https://www.gnu.org/licenses/>.
+;;; Copyright © 2021-2022 Timotej Lazar <timotej.lazar@araneo.si>
+;;; Copyright © 2023 Eidvilas Markevičius <markeviciuseidvilas@gmail.com>
(define-module (nongnu packages gog)
#:use-module (gnu packages boost)
@@ -27,13 +16,13 @@
#:use-module (gnu packages xml)
#:use-module (guix packages)
#:use-module (guix git-download)
- #:use-module (guix build-system cmake)
+ #:use-module (guix build-system qt)
#:use-module ((guix licenses) #:prefix license:))
(define-public lgogdownloader
(package
(name "lgogdownloader")
- (version "3.9")
+ (version "3.12")
(source
(origin
(method git-fetch)
@@ -42,8 +31,8 @@
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1hbwgwdm1vn7lkz366q9q8f44sk1pvhgjffndwx49lh3md66xps2"))))
- (build-system cmake-build-system)
+ (base32 "0kmz5zsbci7iilbqdvql9c1vk2b1q2flsdr6psnkln07xp664di2"))))
+ (build-system qt-build-system)
(arguments
`(#:configure-flags '("-DUSE_QT_GUI=ON")
#:tests? #f)) ; no tests
@@ -54,9 +43,9 @@
jsoncpp
liboauth
qtbase-5
- qtdeclarative
- qtwebchannel
- qtwebengine
+ qtdeclarative-5
+ qtwebchannel-5
+ qtwebengine-5
rhash
tinyxml2
zlib))