summaryrefslogtreecommitdiff
path: root/nongnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'nongnu/packages/linux.scm')
-rw-r--r--nongnu/packages/linux.scm31
1 files changed, 17 insertions, 14 deletions
diff --git a/nongnu/packages/linux.scm b/nongnu/packages/linux.scm
index a18ed7e..ede036f 100644
--- a/nongnu/packages/linux.scm
+++ b/nongnu/packages/linux.scm
@@ -133,6 +133,9 @@ some freedo package or an output of package-version procedure."
"The unmodified Linux kernel, including nonfree blobs, for running Guix System
on hardware which requires nonfree software to function."))))
+(define-public linux-6.9
+ (corrupt-linux linux-libre-6.9))
+
(define-public linux-6.8
(corrupt-linux linux-libre-6.8))
@@ -154,7 +157,7 @@ on hardware which requires nonfree software to function."))))
(define-public linux-4.19
(corrupt-linux linux-libre-4.19))
-(define-public linux linux-6.8)
+(define-public linux linux-6.9)
;; linux-lts points to the *newest* released long-term support version.
(define-public linux-lts linux-6.6)
@@ -216,7 +219,7 @@ on hardware which requires nonfree software to function."))))
(xanmod-defconfig "config_x86-64-v1"))
(define %default-extra-linux-options
- (@@ (gnu packages linux) %default-extra-linux-options))
+ ((@@ (gnu packages linux) default-extra-linux-options) version))
(define config->string
(@@ (gnu packages linux) config->string))
@@ -276,17 +279,17 @@ distribution with custom settings and new features. It's built to provide a
stable, responsive and smooth desktop experience.")))
;; Linux-XanMod sources
-(define-public linux-xanmod-version "6.8.6")
+(define-public linux-xanmod-version "6.9.3")
(define-public linux-xanmod-revision "xanmod1")
(define-public linux-xanmod-source
(make-linux-xanmod-source
linux-xanmod-version
linux-xanmod-revision
#:xanmod-branch "main"
- #:kernel-hash (base32 "1wv5x7qhcd05m8m0myyqm2il6mha1sx11h7ppf8yjsxvx2jdwsf9")
- #:xanmod-hash (base32 "1ry4qmsis7s2bb6hpkvq30ffgvhzj1w33js67ybnvagzda5vbmci")))
+ #:kernel-hash (base32 "0jc14s7z2581qgd82lww25p7c4w72scpf49z8ll3wylwk3xh3yi4")
+ #:xanmod-hash (base32 "100xmh3v3gskdg5ak18r00ka8drjg4vq7n4h7h2d06ibp8r0vhcn")))
-(define-public linux-xanmod-lts-version "6.6.27")
+(define-public linux-xanmod-lts-version "6.6.32")
(define-public linux-xanmod-lts-revision "xanmod1")
(define-public linux-xanmod-lts-source
(make-linux-xanmod-source
@@ -294,7 +297,7 @@ stable, responsive and smooth desktop experience.")))
linux-xanmod-lts-revision
#:xanmod-branch "lts"
#:kernel-hash (base32 "1l2nisx9lf2vdgkq910n5ldbi8z25ky1zvl67zgwg2nxcdna09nr")
- #:xanmod-hash (base32 "0inlpdscdpqahwlsf8kc2zjp2p83yr2cfqyaxld6m4bjkbg23lvz")))
+ #:xanmod-hash (base32 "16kwzz0k9y9jvzrcrn4l5p647xxxla0jhdf2mrwgrz32zg90ndap")))
;; Linux-XanMod packages
(define-public linux-xanmod
@@ -315,14 +318,14 @@ stable, responsive and smooth desktop experience.")))
(define-public linux-firmware
(package
(name "linux-firmware")
- (version "20240312")
+ (version "20240513")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/linux/kernel/firmware/"
"linux-firmware-" version ".tar.xz"))
(sha256
(base32
- "152bpl3lzd7jb2z1cl1sfax6jm71bspn7bwc00lci5qqmma7lcmj"))))
+ "0knc7qgk4bkcdip0hvjnwk4jv062m8cdskywrqvms4v8jswys1cz"))))
(build-system gnu-build-system)
(arguments
(list #:tests? #f
@@ -805,8 +808,8 @@ network adapters.")
(license gpl2))))
(define-public rtl8821ce-linux-module
- (let ((commit "66983b69120a13699acf40a12979317f29012111")
- (revision "11"))
+ (let ((commit "f119398d868b1a3395f40c1df2e08b57b2c882cd")
+ (revision "12"))
(package
(name "rtl8821ce-linux-module")
(version (git-version "0.0.0" revision commit))
@@ -819,7 +822,7 @@ network adapters.")
(file-name (git-file-name name version))
(sha256
(base32
- "0kj12jll0df1h4z6kzv3vylh22xlniki5kg414fv9sqgx1qgs5k7"))))
+ "03336fzhcyfkxa32rx0calzlyzamvinql5f19wwm61aijrmlmyhi"))))
(build-system linux-module-build-system)
(arguments
(list #:make-flags
@@ -1184,7 +1187,7 @@ driver:
(define-public intel-microcode
(package
(name "intel-microcode")
- (version "20240312")
+ (version "20240531")
(source
(origin
(method git-fetch)
@@ -1195,7 +1198,7 @@ driver:
(commit (string-append "microcode-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1j1krkmp9kxmpq8bbbld8bm3y9rqhmlj5qfm43czikawnpw81571"))))
+ (base32 "1r9l42qsz2rj0zcknvj37q595xcbmisqf10f8rwjb2nlrl8xr2zb"))))
(build-system copy-build-system)
(arguments
(list #:install-plan