summaryrefslogtreecommitdiff
path: root/nongnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'nongnu/packages/linux.scm')
-rw-r--r--nongnu/packages/linux.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/nongnu/packages/linux.scm b/nongnu/packages/linux.scm
index 8c4e2fe..380dc1c 100644
--- a/nongnu/packages/linux.scm
+++ b/nongnu/packages/linux.scm
@@ -63,7 +63,14 @@
(source (origin
(method url-fetch)
(uri (linux-urls version))
- (sha256 (base32 hash))))
+ (sha256 (base32 hash))
+ ;; By default the linux-libre package will "make infodocs" for
+ ;; supported kernels (version > 5.10) which needs the following
+ ;; patch. Include the patch if it applies rather than disabling
+ ;; the associated "build-doc" phase.
+ (patches (if ((@@ (gnu packages linux) doc-supported?) version)
+ (search-patches "linux-libre-infodocs-target.patch")
+ '()))))
(home-page "https://www.kernel.org/")
(synopsis "Linux kernel with nonfree binary blobs included")
(description