summaryrefslogtreecommitdiff
path: root/nongnu/packages/mozilla.scm
diff options
context:
space:
mode:
Diffstat (limited to 'nongnu/packages/mozilla.scm')
-rw-r--r--nongnu/packages/mozilla.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/nongnu/packages/mozilla.scm b/nongnu/packages/mozilla.scm
index 09f050e..8d43b2e 100644
--- a/nongnu/packages/mozilla.scm
+++ b/nongnu/packages/mozilla.scm
@@ -334,6 +334,11 @@ according to Unicode Standard Annex #31")
;; XDG settings should be managed by Guix.
(write-setting "browser.shell.checkDefaultBrowser" "false")
(close-port port))))
+ (add-after 'fix-preferences 'fix-store-permissions
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Piggyback off of (and overwrite) the existing NixOS sandbox policy
+ (substitute* "security/sandbox/linux/broker/SandboxBrokerPolicyFactory.cpp"
+ (("/nix/store") "/gnu/store"))))
(add-after 'fix-preferences 'fix-ffmpeg-runtime-linker
(lambda* (#:key inputs #:allow-other-keys)
(let* ((ffmpeg (assoc-ref inputs "ffmpeg"))