summaryrefslogtreecommitdiff
path: root/nongnu/packages/vpn.scm
diff options
context:
space:
mode:
Diffstat (limited to 'nongnu/packages/vpn.scm')
-rw-r--r--nongnu/packages/vpn.scm29
1 files changed, 7 insertions, 22 deletions
diff --git a/nongnu/packages/vpn.scm b/nongnu/packages/vpn.scm
index 856a45b..ad3bb8a 100644
--- a/nongnu/packages/vpn.scm
+++ b/nongnu/packages/vpn.scm
@@ -1,21 +1,5 @@
-;;; GNU Guix --- Functional package management for GNU
+;;; SPDX-License-Identifier: GPL-3.0-or-later
;;; Copyright © 2020 Alexey Abramov <levenson@mmer.org>
-;;;
-;;; This file is not part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
(define-module (nongnu packages vpn)
#:use-module (guix build utils)
@@ -28,7 +12,7 @@
(define-public zerotier
(package
(name "zerotier")
- (version "1.8.4")
+ (version "1.12.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -37,16 +21,17 @@
(file-name (git-file-name name version))
(sha256
(base32
- "101b1k9f3cpbgj0l87ya1cbqs9dv0qiayjap4m29fxyjra8hbkb8"))))
+ "0p5rpvh137gf5y9ylip7kxfl4argv34sr4wiiygvfk670rifnk57"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
+ `(#:make-flags (list "ZT_SSO_SUPPORTED=0") ; We don't need SSO/OIDC
+ #:phases
(modify-phases %standard-phases
;; There is no ./configure
(delete 'configure)
(replace 'check
- (lambda _
- (invoke "make" "selftest")
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke "make" "selftest" make-flags)
(invoke "./zerotier-selftest")))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)