summaryrefslogtreecommitdiff
path: root/nongnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'nongnu/packages')
-rw-r--r--nongnu/packages/linux.scm4
-rw-r--r--nongnu/packages/mozilla.scm12
-rw-r--r--nongnu/packages/video.scm4
3 files changed, 10 insertions, 10 deletions
diff --git a/nongnu/packages/linux.scm b/nongnu/packages/linux.scm
index a18ed7e..b0dc3c0 100644
--- a/nongnu/packages/linux.scm
+++ b/nongnu/packages/linux.scm
@@ -1184,7 +1184,7 @@ driver:
(define-public intel-microcode
(package
(name "intel-microcode")
- (version "20240312")
+ (version "20240514")
(source
(origin
(method git-fetch)
@@ -1195,7 +1195,7 @@ driver:
(commit (string-append "microcode-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1j1krkmp9kxmpq8bbbld8bm3y9rqhmlj5qfm43czikawnpw81571"))))
+ (base32 "1s95rxz6sdpnhd9zn374yd5qjwgxhbhf6wknnd8xj7iksh1fawg9"))))
(build-system copy-build-system)
(arguments
(list #:install-plan
diff --git a/nongnu/packages/mozilla.scm b/nongnu/packages/mozilla.scm
index 0588ad6..b6fdec9 100644
--- a/nongnu/packages/mozilla.scm
+++ b/nongnu/packages/mozilla.scm
@@ -97,19 +97,19 @@
;; Update this id with every firefox update to its release date.
;; It's used for cache validation and therefore can lead to strange bugs.
-(define %firefox-esr-build-id "20240415130026")
+(define %firefox-esr-build-id "20240513132822")
(define-public firefox-esr
(package
(name "firefox-esr")
- (version "115.10.0esr")
+ (version "115.11.0esr")
(source
(origin
(method url-fetch)
(uri (string-append "https://archive.mozilla.org/pub/firefox/releases/"
version "/source/firefox-" version ".source.tar.xz"))
(sha256
- (base32 "1wpf4vcrvnvhnfzqavbkzqbn51bds1l9f6ld4mzh9xwm7mrkrz8a"))))
+ (base32 "1q15c318b5k8b5cady3w0xpwyala9ji0a62lsf5jnsimdbqldghn"))))
(build-system gnu-build-system)
(arguments
(list
@@ -532,20 +532,20 @@ MOZ_ENABLE_WAYLAND=1 exec ~a $@\n"
;; Update this id with every firefox update to its release date.
;; It's used for cache validation and therefore can lead to strange bugs.
-(define %firefox-build-id "20240429124342")
+(define %firefox-build-id "20240513130807")
(define-public firefox
(package
(inherit firefox-esr)
(name "firefox")
- (version "125.0.3")
+ (version "126.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://archive.mozilla.org/pub/firefox/releases/"
version "/source/firefox-" version ".source.tar.xz"))
(sha256
- (base32 "05jnpnc0qym08f7rlapjm36g729445k3nba2rvf4a0sabsw6c726"))))
+ (base32 "09l5hsyrkimmkd7wbhnamy5mwmwwxjfa742hpkjjkhlyk6hq43li"))))
(arguments
(substitute-keyword-arguments (package-arguments firefox-esr)
((#:phases phases)
diff --git a/nongnu/packages/video.scm b/nongnu/packages/video.scm
index 2d564d7..e5af3a1 100644
--- a/nongnu/packages/video.scm
+++ b/nongnu/packages/video.scm
@@ -42,7 +42,7 @@ for VAAPI.")
(define-public intel-media-driver
(package
(name "intel-media-driver")
- (version "23.4.3")
+ (version "24.1.5")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -51,7 +51,7 @@ for VAAPI.")
(file-name (git-file-name name version))
(sha256
(base32
- "0rgjakygfzy6d3jz38nnjvcvqyjnwz2b4vfh1ifqfcm3bw56fmr9"))))
+ "1jm4imld48scj0j499wq5zbdjv4gg7hg2sawljqnjvy09dmp09bs"))))
(build-system cmake-build-system)
(inputs (list libva gmmlib))
(native-inputs (list pkg-config))