summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2020-12-05 15:29:49 +0100
committerVivien Kraus <vivien@planete-kraus.eu>2021-05-11 00:14:27 +0200
commitac2d90e8052bc399d0bf04ad520947cab540f59c (patch)
treefed65aed4ec442bfbef2e48d1164e5e9f820faf9 /configure.ac
parent84dcc91c1001c8a6499a58596ac6edaf40c80d97 (diff)
Check that the code is indented on distcheck.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0331d87..2bb125c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,10 +3,15 @@ AC_CONFIG_SRCDIR([src/libwebidoidc.c])
AM_INIT_AUTOMAKE([subdir-objects])
AM_SILENT_RULES([yes])
+AC_ARG_ENABLE([--enable-indent-check],
+ [When running tests, also check that the source code is indented])
+
+AM_CONDITIONAL([INDENT_CHECK_ENABLED], [test "x$enable_indent_check" = "xyes"])
AC_PROG_CC
AM_MISSING_PROG([SNARF], [guile-snarf])
AM_MISSING_PROG([HELP2MAN], [help2man])
AM_MISSING_PROG([XSLTPROC], [xsltproc])
+AM_MISSING_PROG([INDENT], [indent])
LT_INIT
AC_CONFIG_HEADERS([config.h])
AM_GNU_GETTEXT([external])