summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2020-01-01 00:00:00 +0100
committerVivien Kraus <vivien@planete-kraus.eu>2021-05-11 00:14:27 +0200
commitd33b47eb282d6b46378e88df3693caa7ce4f1cce (patch)
treebb36ca3a8975ca2985b063a2971e59cc4cbf0a5c /tests/Makefile.am
parentb021d3c7188a5705a858144c0bdd8e6a962fc677 (diff)
Add a random number generator.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am13
1 files changed, 10 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 12699f9..7efc3d1 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,12 +1,19 @@
-TESTS = \
- %reldir%/load-library.scm \
+TESTS = %reldir%/load-library.scm \
%reldir%/base64-ok.scm \
- %reldir%/base64-error.scm
+ %reldir%/base64-error.scm \
+ %reldir%/random.scm
EXTRA_DIST += $(TESTS)
TEST_EXTENSIONS = .scm
+.PHONY: %canon_reldir%-clean-local
+
+clean-local: %canon_reldir%-clean-local
+
+%canon_reldir%-clean-local:
+ rm -rf %reldir%/*.cache
+
AM_TESTS_ENVIRONMENT = $(top_builddir)/pre-inst-env
SCM_LOG_COMPILER = $(GUILE)
AM_SCM_LOG_FLAGS = --no-auto-compile -s