summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2020-11-27 19:28:50 +0100
committerVivien Kraus <vivien@planete-kraus.eu>2021-06-05 16:10:10 +0200
commit7e125cc85c79e0854ca300dec6f819598e3fc6b0 (patch)
tree95975158f3f0aaab4d0f4b06be4ed6b973adfe8f /tests/Makefile.am
parent7f89251db6ef11f4becd59d528ce9ab3e1180504 (diff)
Add a base64 encoder and decoder
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 1e4b2df..12699f9 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,4 +1,7 @@
-TESTS = %reldir%/load-library.scm
+TESTS = \
+ %reldir%/load-library.scm \
+ %reldir%/base64-ok.scm \
+ %reldir%/base64-error.scm
EXTRA_DIST += $(TESTS)
@@ -7,3 +10,9 @@ TEST_EXTENSIONS = .scm
AM_TESTS_ENVIRONMENT = $(top_builddir)/pre-inst-env
SCM_LOG_COMPILER = $(GUILE)
AM_SCM_LOG_FLAGS = --no-auto-compile -s
+
+clean-local: %canon_reldir%-clean-local
+
+%canon_reldir%-clean-local:
+ rm -rf %reldir%/*.cache
+ rm -rf %reldir%/*.home