summaryrefslogtreecommitdiff
path: root/src/client/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/client/Makefile.am')
-rw-r--r--src/client/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/client/Makefile.am b/src/client/Makefile.am
new file mode 100644
index 0000000..20a17a7
--- /dev/null
+++ b/src/client/Makefile.am
@@ -0,0 +1,25 @@
+# disfluid, implementation of the Solid specification
+# Copyright (C) 2020, 2021 Vivien Kraus
+
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as
+# published by the Free Software Foundation, either version 3 of the
+# License, or (at your option) any later version.
+
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Affero General Public License for more details.
+
+# You should have received a copy of the GNU Affero General Public License
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+noinst_LTLIBRARIES += %reldir%/libwebidoidc-client.la
+
+include_HEADERS += %reldir%/Disfluid-0.h
+
+%canon_reldir%_libwebidoidc_client_la_LIBADD = $(GUILE_LIBS)
+
+AM_CFLAGS += -I %reldir% -I $(srcdir)/%reldir%
+
+INDENTED += %reldir%/libwebidoidc-client.c %reldir%/Disfluid-0.h