summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-04-22 13:34:24 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-05-11 21:57:16 +0200
commit186d4f8d08b8c25ceddcc1caf03a9cf1323110db (patch)
tree695d9ead318a48ec0868ec39df550d02cb8761aa
parent03ded2fd3be2b6fbff13df58643edf29601badf4 (diff)
gnu: Add python-diff-match-patch.
* gnu/packages/python.scm (python-diff-match-patch, python2-diff-match-patch): New variables.
-rw-r--r--gnu/packages/python.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 13eeefed1e..d6470dbe92 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14282,3 +14282,24 @@ use in your Sphinx docs.")
(define-public python2-cssmin
(package-with-python2 python-cssmin))
+
+(define-public python-diff-match-patch
+ (package
+ (name "python-diff-match-patch")
+ (version "20121119")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "diff-match-patch" version))
+ (sha256
+ (base32
+ "0k1f3v8nbidcmmrk65m7h8v41jqi37653za9fcs96y7jzc8mdflx"))))
+ (build-system python-build-system)
+ (home-page "https://code.google.com/p/google-diff-match-patch")
+ (synopsis "Synchronize plain text")
+ (description "Diff Match and Patch libraries offer robust algorithms to
+perform the operations required for synchronizing plain text.")
+ (license license:asl2.0)))
+
+(define-public python2-diff-match-patch
+ (package-with-python2 python-diff-match-patch))