summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-04-22 14:00:09 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-05-11 21:57:21 +0200
commit1b16f1ecb19924899cf8d9831f6ebfd57143aec4 (patch)
tree9ac2a6b29d04e6b63b757be52724ca798451329c
parentd15a47911adde0a2f684d30df594d4b0ace8367b (diff)
gnu: Add python-nosexcover.
* gnu/packages/python.scm (python-nosexcover, python2-nosexcover): New variables.
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 817e058f99..2f2da39aac 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14327,3 +14327,30 @@ perform the operations required for synchronizing plain text.")
(define-public python2-dirsync
(package-with-python2 python-dirsync))
+
+(define-public python-nosexcover
+ (package
+ (name "python-nosexcover")
+ (version "1.0.11")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "nosexcover" version))
+ (sha256
+ (base32
+ "10xqr12qv62k2flxwqhh8cr00cjhn7sfjrm6p35gd1x5bmjkr319"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-nose" ,python-nose)))
+ (home-page "http://github.com/cmheisel/nose-xcover")
+ (synopsis "Extends nose.plugins.cover to add Cobertura-style XML reports")
+ (description "Nose-xcover is a companion to the built-in
+@code{nose.plugins.cover}. This plugin will write out an XML coverage report
+to a file named coverage.xml.
+
+It will honor all the options you pass to the Nose coverage plugin,
+especially -cover-package.")
+ (license license:expat)))
+
+(define-public python2-nosexcover
+ (package-with-python2 python-nosexcover))