summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-04-22 13:39:13 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-05-11 21:57:18 +0200
commitd15a47911adde0a2f684d30df594d4b0ace8367b (patch)
tree27b029a0d6bc99753c9c29a3ec28776311358aa2
parent186d4f8d08b8c25ceddcc1caf03a9cf1323110db (diff)
gnu: Add python-dirsync.
* gnu/packages/python.scm (python-dirsync, python2-dirsync): New variables.
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d6470dbe92..817e058f99 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14303,3 +14303,27 @@ perform the operations required for synchronizing plain text.")
(define-public python2-diff-match-patch
(package-with-python2 python-diff-match-patch))
+
+(define-public python-dirsync
+ (package
+ (name "python-dirsync")
+ (version "2.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "dirsync" version ".zip"))
+ (sha256
+ (base32
+ "1hcdvmkwd5512zbxpin0k7bx5bkgzy3swjx7d0kj1y45af6r75v2"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("unzip" ,unzip)))
+ (propagated-inputs
+ `(("six" ,python-six)))
+ (home-page "https://bitbucket.org/tkhyn/dirsync")
+ (synopsis "Advanced directory tree synchronisation tool")
+ (description "Advanced directory tree synchronisation tool.")
+ (license license:expat)))
+
+(define-public python2-dirsync
+ (package-with-python2 python-dirsync))