summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-22 21:11:51 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-27 21:33:28 +0000
commit2173e4a12ea7188c402c943b6870348253520da8 (patch)
tree8f71bbe6c49788c8bfa6b4021f4a20e3dced0566
parentf427ec7026110e74cb36b506f5eb4c52fa556079 (diff)
gnu: go-github-com-alecthomas-kingpin: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-alecthomas-kingpin): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Ib7609a82c96683809f81479f4eb13f43d85d4a2f
-rw-r--r--gnu/packages/golang-xyz.scm33
-rw-r--r--gnu/packages/golang.scm29
2 files changed, 32 insertions, 30 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 84b17a1390..8156cff05e 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -5,10 +5,11 @@
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2019 Vagrant Cascadian <vagrant@debian.org>
-;;; Copyright © 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019-2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020, 2021 raingloom <raingloom@riseup.net>
+;;; Copyright © 2021 Collin J. Doering <collin@rekahsoft.ca>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
@@ -142,6 +143,36 @@ syntax highlighted HTML, ANSI-coloured text, etc.")
(list go-github-com-alecthomas-assert-v2
go-github-com-alecthomas-repr))))
+(define-public go-github-com-alecthomas-kingpin
+ (package
+ (name "go-github-com-alecthomas-kingpin")
+ (version "2.2.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alecthomas/kingpin")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0mndnv3hdngr3bxp7yxfd47cas4prv98sqw534mx7vp38gd88n5r"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/alecthomas/kingpin"))
+ (native-inputs
+ (list go-github-com-alecthomas-template
+ go-github-com-alecthomas-units
+ go-github-com-stretchr-testify))
+ (home-page "https://github.com/alecthomas/kingpin")
+ (synopsis "Go library provides utilities for building command line interfaces")
+ (description
+ "Go library provides utilities for building command line interfaces.")
+ (license license:expat)))
+
+(define-public go-github-com-kingpin
+ (deprecated-package "go-github-com-kingpin" go-github-com-alecthomas-kingpin))
+
(define-public go-github-com-alecthomas-participle-v2
(package
(name "go-github-com-alecthomas-participle-v2")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6533914f80..062985c0ce 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9609,35 +9609,6 @@ GNU/Linux, this is a proxy for the @command{xdg-open} command.")
(home-page "https://github.com/skratchdot/open-golang")
(license license:expat))))
-(define-public go-github-com-alecthomas-kingpin
- (package
- (name "go-github-com-alecthomas-kingpin")
- (version "2.2.6")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/alecthomas/kingpin")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0mndnv3hdngr3bxp7yxfd47cas4prv98sqw534mx7vp38gd88n5r"))))
- (build-system go-build-system)
- (native-inputs
- (list go-github-com-alecthomas-template go-github-com-alecthomas-units
- go-github-com-stretchr-testify))
- (arguments
- '(#:import-path "github.com/alecthomas/kingpin"
- #:phases %standard-phases))
- (synopsis "Go library provides utilities for building command line interfaces")
- (description
- "Go library provides utilities for building command line interfaces.")
- (home-page "https://github.com/alecthomas/kingpin")
- (license license:expat)))
-
-(define-public go-github-com-kingpin
- (deprecated-package "go-github-com-kingpin" go-github-com-alecthomas-kingpin))
-
(define-public go-github-com-alecthomas-template
(let ((commit "a0175ee3bccc567396460bf5acd36800cb10c49c")
(revision "0"))