summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author(unmatched-parenthesis <paren@disroot.org>2022-10-21 22:11:20 +0100
committerRaghav Gururajan <rg@raghavgururajan.name>2022-11-27 10:31:10 -0500
commit26e57c23187416bfb285c49687a968fdcdd9c586 (patch)
tree32ac7425ab35ae01157dcea625e9c983a9a9e19b
parent4118197603cab6bedad4172627e375913499a673 (diff)
gnu: Add go-github-com-emersion-go-smtp.
* gnu/packages/golang.scm (go-github-com-emersion-go-smtp): New variable. Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4dba288877..0e3a5d6d19 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6669,6 +6669,30 @@ can be used to build IMAP clients and servers.")
@code{go-github-com-emersion-go-imap}.")
(license license:expat)))
+(define-public go-github-com-emersion-go-smtp
+ (package
+ (name "go-github-com-emersion-go-smtp")
+ (version "0.15.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/go-smtp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1vhc0vpjd4yhxk6wrh01sdpi7nprjn98s46yy82xwlkm0cskl0h7"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/emersion/go-smtp"))
+ (propagated-inputs (list go-github-com-emersion-go-sasl))
+ (home-page "https://github.com/emersion/go-smtp")
+ (synopsis "SMTP implementation for Go")
+ (description
+ "This package implements the Simple Mail Transfer Protocol as
+defined by RFC 5321.")
+ (license license:expat)))
+
(define-public go-github-com-emersion-go-sasl
(let ((commit "0b9dcfb154ac3d7515b08bc2691a0332800edfe9")
(revision "1"))