summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Sankey <sankeytms@gmail.com>2016-08-13 12:08:05 -0400
committerMark H Weaver <mhw@netris.org>2016-08-23 06:38:07 -0400
commit37ec462392f9c645274ddf7ce020cbb3dd589332 (patch)
tree203488f113263f9251b9f3e38833494c4479eaba
parent51ff41f63f780cb22e6a79fa5ed845c382222910 (diff)
gnu: python-urwidtrees: Update to 1.0.2.
* gnu/packages/python.scm (python-urwidtrees): Update to 1.0.2. Add note about distribution method. Signed-off-by: Mark H Weaver <mhw@netris.org>
-rw-r--r--gnu/packages/python.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index cd90c52184..79b67a5b95 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4521,14 +4521,18 @@ features useful for text console applications.")
(define-public python-urwidtrees
(package
(name "python-urwidtrees")
- (version "1.0.1.1")
+ (version "1.0.2")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "urwidtrees" version))
+ ;; package author intends on distributing via github rather than pypi:
+ ;; https://github.com/pazz/alot/issues/877#issuecomment-230173331
+ (uri (string-append "https://github.com/pazz/urwidtrees/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1zcvy12s7h3fazf33d6y7b4v19p8hg95xqwhqlmw6jz9fq76v9h8"))))
+ "0d30lyd3s2a97rhqfax5w9ssqds2z6aydqx3c6j2c2lk3cb4ngvh"))))
(build-system python-build-system)
(arguments
'(#:tests? #f)) ; no tests