summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-27 06:36:19 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-27 06:36:19 +0200
commit3b19fc18012c80d2af24ab83bd705ac59b2b7134 (patch)
treea41377dd5b259c5b29d930d8191527cce26701cc
parentf95498c92e48dc731be538dda67ff112dcfce98e (diff)
gnu: python-httpcore: Update to 0.17.0.
* gnu/packages/python-web.scm (python-httpcore): Update to 0.17.0. [build-system]: Use pyproject-build-system. [arguments]: Remove custom check phase; specify #:test-flags; disable broken tests.
-rw-r--r--gnu/packages/python-web.scm32
1 files changed, 22 insertions, 10 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d6dd1032aa..9d2aa697c3 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5838,7 +5838,7 @@ and serve updated contents upon changes to the directory.")
(define-public python-httpcore
(package
(name "python-httpcore")
- (version "0.15.0")
+ (version "0.17.0")
(source
(origin
;; PyPI tarball does not contain tests.
@@ -5848,16 +5848,28 @@ and serve updated contents upon changes to the directory.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0skj8f85l52gl6x449wzaixcwsyayvn59iwn0df4b7ixlz6xhp8l"))))
- (build-system python-build-system)
+ (base32 "0qf2w6sgn51jd41a4k230jincrk6rchgc0k1bclxhyyzv44q4q8c"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv" "tests"
- "--override-ini=asyncio_mode=auto")))))))
+ (list
+ #:test-flags
+ '(list "--override-ini=asyncio_mode=auto"
+ "-k"
+ (string-join '("not test_ssl_request"
+ ;; PytestUnraisableExceptionWarning
+ "test_authenticated_socks5_request"
+ "test_socks5_request"
+ "test_socks5_request_connect_failed"
+ "test_socks5_request_failed_to_provide_auth"
+ "test_socks5_request_incorrect_auth"
+ ;; marked with @pytest.mark.asyncio but it is not an async function
+ "test_connection_pool_concurrency"
+ "test_connection_pool_concurrency_same_domain_keepalive"
+ "test_response_async_read"
+ "test_response_async_streaming"
+ ;; SSL connection has been closed
+ "test_extra_info")
+ " and not "))))
(native-inputs
(list python-pytest
python-pytest-asyncio