summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authornafkhamdc <navid.afkhami@mdc-berlin.de>2024-03-26 11:03:36 +0000
committerRicardo Wurmus <rekado@elephly.net>2024-03-27 15:10:15 +0100
commit3feb8f7f0227729ea15bdc84957f5d2e8c6ed117 (patch)
treebb0e7a645d55c484996cb3e5e349881c27b74086
parent64db5d6de377832a3ae73b22e1028cceff178e56 (diff)
gnu: Add python-icecream.
* gnu/packages/python-xyz.scm (python-icecream): New variable. Change-Id: I866d0ce591a1b81fdd7e0ee706cb8e9791e70c49 Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/python-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index aad89d251e..0e49c105f6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -150,6 +150,7 @@
;;; Copyright © 2024 Timothee Mathieu <timothee.mathieu@inria.fr>
;;; Copyright © 2024 Ian Eure <ian@retrospec.tv>
;;; Copyright © 2024 Adriel Dumas--Jondeau <leirda@disroot.org>
+;;; Copyright © 2024 Navid Afkhami <navid.afkhami@mdc-berlin.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -35997,6 +35998,36 @@ The database contains over 6.5 million entries, over 3.1 million unique word
forms, and about 300,000 distinct lemmas.")
(license license:expat)))
+(define-public python-icecream
+ (package
+ (name "python-icecream")
+ (version "2.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "icecream" version))
+ (sha256
+ (base32 "1pj9kf7lwm799wppvngg3sndi0qf13iq33yhl59n3hsf6z1sg90a"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ '(list "-k"
+ ;; These tests are failing due to a bug:
+ ;; https://github.com/gruns/icecream/issues/144
+ (string-append "not testEnableDisable"
+ " and not testSingledispatchArgumentToString"))))
+ (propagated-inputs (list python-asttokens python-colorama python-executing
+ python-pygments))
+ (native-inputs (list python-hypothesis python-pytest))
+ (home-page "https://github.com/gruns/icecream")
+ (synopsis
+ "Single function call to debug variables, expressions, and program execution")
+ (description
+ "This tool lets you debug variables, expressions, and program execution
+with one function call. IceCream makes print debugging a little sweeter.")
+ (license license:expat)))
+
(define-public python-icegrams
(package
(name "python-icegrams")