summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:20:44 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:43 +0200
commit4061203dd560fc670b2dd9518e05116c57f3ce0e (patch)
tree3e38c5f86c1782dbe3636aabe08bd88ab01ff5ea
parent43883eb82b4b83726d814ee24a4d4055f62c976c (diff)
gnu: Add texlive-pkfix.
* gnu/packages/tex.scm (texlive-pkfix): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 13accf6911..f54aae9029 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3148,6 +3148,27 @@ as a booklet. Justen made two Bash scripts for this job; the package provides
one Texlua script for both requirements.")
(license license:lppl1.3+)))
+(define-public texlive-pkfix
+ (package
+ (name "texlive-pkfix")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/support/pkfix/" "scripts/pkfix/")
+ (base32
+ "173l1qaydv29va9cgip9p3i3vf27x6ndsqjm4nvdpliblai6fkwf")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "pkfix.pl")))
+ (inputs (list perl))
+ (home-page "https://ctan.org/pkg/pkfix")
+ (synopsis "Replace PK fonts in PostScript with Type 1 fonts")
+ (description
+ "The Perl script @command{pkfix} looks for DVIPSBitmapFont comments in
+PostScript files, generated by not too old dvips, and replaces them by type
+1 versions of the fonts, if possible.")
+ (license license:lppl1.3+)))
+
(define-public texlive-tex-ini-files
(package
(name "texlive-tex-ini-files")