summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-04-22 13:22:46 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-05-11 21:57:08 +0200
commit4c066b727c4765a066213a7f1399629e89119721 (patch)
tree4068b83ab93d528ae67eb7c06cda611073d8ee65
parent709a5a9365ac6115d9f8ddd29502f78f70649497 (diff)
gnu: Add python-sphinx-me.
* gnu/packages/python.scm (python-sphinx-me, python2-sphinx-me): New variables.
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 6ee3163c6f..e3402f0803 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14240,3 +14240,27 @@ make common patterns shorter and easier.")
supporting a variety of different filters, including YUI, jsmin, jspacker or
CSS tidy. Also supports URL rewriting in CSS files.")
(license license:bsd-2)))
+
+(define-public python-sphinx-me
+ (package
+ (name "python-sphinx-me")
+ (version "0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sphinx-me" version))
+ (sha256
+ (base32
+ "06jzgp213zihnvpcy2y5jy3ykid3apc2ncp2pg6a2g05lhiziglq"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/stephenmcd/sphinx-me")
+ (synopsis "Create a Sphinx documentation shell")
+ (description
+ "Create a Sphinx documentation shell for your project and include the
+README file as the documentation index. It handles extracting the required
+meta data such as the project name, author and version from your project for
+use in your Sphinx docs.")
+ (license license:bsd-2)))
+
+(define-public python2-sphinx-me
+ (package-with-python2 python-sphinx-me))