summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-04-21 10:16:38 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-21 12:56:39 +0200
commit5107a8a1a394fef300c2d98d36b1bd92122ecf39 (patch)
treede97fd846103b90ce815377dd23a52c443763722
parent627049872b500adc2d731758938efa28e1415a49 (diff)
gnu: bpp-phyl: Update to 2.4.1.
* gnu/packages/bioinformatics.scm (bpp-phyl): Update to 2.4.1. [source]: Remove the commit and use the release version. Changed to the github repo. [arguments]: Remove the disabled parallel-build and out-of-source. [home-page]: Changed to new host Université Claude-Bernard Lyon 1. [synopsis]: Use proper capitalization.
-rw-r--r--gnu/packages/bioinformatics.scm49
1 files changed, 20 insertions, 29 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 232d0e42c6..ad61b979dd 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2244,37 +2244,28 @@ providing them a set of re-usable tools.")
(license license:cecill-c)))
(define-public bpp-phyl
- ;; The last release was in 2014 and the recommended way to install from source
- ;; is to clone the git repository, so we do this.
- ;; http://biopp.univ-montp2.fr/wiki/index.php/Main_Page
- (let ((commit "0c07167b629f68b569bf274d1ad0c4af83276ae2"))
- (package
- (name "bpp-phyl")
- (version (string-append "2.2.0-1." (string-take commit 7)))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "http://biopp.univ-montp2.fr/git/bpp-phyl")
- (commit commit)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "1ssjgchzwj3iai26kyly7gwkdv8sk59nqhkb1wpap3sf5m6kyllh"))))
- (build-system cmake-build-system)
- (arguments
- `(#:parallel-build? #f
- ;; If out-of-source, test data is not copied into the build directory
- ;; so the tests fail.
- #:out-of-source? #f))
- (inputs
- (list bpp-core bpp-seq))
- (home-page "http://biopp.univ-montp2.fr")
- (synopsis "Bio++ phylogenetic Library")
- (description
- "Bio++ is a set of C++ libraries for Bioinformatics, including sequence
+ (package
+ (name "bpp-phyl")
+ (version "2.4.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/BioPP/bpp-phyl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "192zks6wyk903n06c2lbsscdhkjnfwms8p7jblsmk3lvjhdipb20"))))
+ (build-system cmake-build-system)
+ (inputs
+ (list bpp-core bpp-seq))
+ (home-page "https://pbil.univ-lyon1.fr/bpp-doc/bpp-phyl/html/")
+ (synopsis "Bio++ phylogenetic library")
+ (description
+ "Bio++ is a set of C++ libraries for Bioinformatics, including sequence
analysis, phylogenetics, molecular evolution and population genetics. This
library provides phylogenetics-related modules.")
- (license license:cecill-c))))
+ (license license:cecill-c)))
(define-public bpp-popgen
;; The last release was in 2014 and the recommended way to install from source