summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-21 21:43:57 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-24 15:31:08 +0100
commit54935b4de9084ea52d2405f07b5b433ea9f3128e (patch)
treefadbeb1eec98890047ae25888b8abfa265835f54
parent4e2b6d5585cc5ab103003cfc7a2f74dff548edfb (diff)
gnu: go-github-com-multiformats-go-multiaddr: Update to 0.1.0.
* gnu/packages/golang-web.scm (go-github-com-multiformats-go-multiaddr): Update to 0.1.0. Change-Id: I3ab2b388915076863304909d5d72c637808eb4ea
-rw-r--r--gnu/packages/golang-web.scm13
1 files changed, 4 insertions, 9 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 91f075ca2e..befef856dd 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1308,23 +1308,18 @@ router.")
(license license:bsd-3)))
(define-public go-github-com-multiformats-go-multiaddr
- ;; This commit is from <2018-10-01> and associated with GX package manager,
- ;; since that time the project has changed versing stile and GX is dropped.
- ;; Current versioned tag is v0.12.2 <2024-01-26>.
- (let ((commit "fe1c46f8be5af4aff4db286e08839295bd922efb")
- (revision "0"))
(package
(name "go-github-com-multiformats-go-multiaddr")
- (version (git-version "1.3.0" revision commit))
+ (version "0.1.0")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/multiformats/go-multiaddr")
- (commit commit)))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0p5f8h098a4yjjmzsgqs7vhx1iqifb8izwg3559cr4h7clkpzznh"))))
+ (base32 "0cdzlzh7cb1pj9mhq45va3r6gs6pcdfa9j7vdrqlv3zd6k3bxg39"))))
(build-system go-build-system)
(arguments
(list
@@ -1344,7 +1339,7 @@ following:
@item Have a nice string representation.
@item Encapsulate well.
@end itemize\n")
- (license license:expat))))
+ (license license:expat)))
(define-public go-github-com-multiformats-go-multiaddr-net
;; This commit is from <2018-10-01> and associated with GX package manager,