summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-28 15:59:08 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-28 16:27:37 +0100
commit5bbb1ab715855d89a963fd198ed5fd4053eb1ca4 (patch)
tree32956ffb8ecc1da92c21964051bdab8b11585393
parent37e35f6f59be0876efdd60f61cd3f3e9b0a2195a (diff)
gnu: Add go-github-com-multiformats-go-multistream.
* gnu/packages/golang-web.scm (go-github-com-multiformats-go-multistream): New variable. Change-Id: Iba20fe848901fa5df59303f1673160f8c75d7831
-rw-r--r--gnu/packages/golang-web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 0879d496cf..12a6da4675 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1457,6 +1457,34 @@ symbols like @command{net.Dial} and @command{net.Listen}, as well as
conversion to and from @command{net.Addr}.")
(license license:expat))))
+(define-public go-github-com-multiformats-go-multistream
+ (package
+ (name "go-github-com-multiformats-go-multistream")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/multiformats/go-multistream")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1mlcz16ii090vq6brm02dmmkj8akkafa55kyvkrrwpq6zvj1hy23"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.20
+ #:import-path "github.com/multiformats/go-multistream"))
+ (propagated-inputs
+ (list go-github-com-multiformats-go-varint))
+ (home-page "https://github.com/multiformats/go-multistream")
+ (synopsis "Implementation of the multistream protocol in Golang")
+ (description
+ "Package multistream implements a simple stream router for the
+multistream-select protocol. The protocol is defined at
+@url{https://github.com/multiformats/multistream-select}")
+ (license license:expat)))
+
(define-public go-github-com-nwidger-jsoncolor
(package
(name "go-github-com-nwidger-jsoncolor")