summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-09 13:51:30 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-09 13:51:30 +0300
commit70833c2ec8b200dbc704b93ff17d78a1e3cc1eed (patch)
treeaa4f040c880b825d1499bd5f262a0daa8c51f483
parent830a47e85d3282c54d5d8e7b79afd7efd96919ec (diff)
gnu: python-markupsafe: Honor #:tests in check phase.
* gnu/pacakges/python-xyz.scm (python-markupsafe)[arguments]: Honor #:tests flag.
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 611451ef55..848efb23d7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3757,8 +3757,9 @@ e.g. filters, callbacks and errbacks can all be promises.")
(arguments
`(#:phases (modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "pytest" "-vv"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv")))))))
(native-inputs
`(("python-pytest" ,python-pytest)))
(home-page "https://github.com/mitsuhiko/markupsafe")