summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-04-20 06:44:08 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-24 15:34:03 +0100
commit79bbd178f1557247536184e2f45911b58e9fe7cc (patch)
tree591ce172c0a82b9bcec70f1bc9e63b45e9a3a0db
parent837841ed661ed2feace52fad52f8fac240c88275 (diff)
gnu: Add go-github-com-multiformats-go-multiaddr-0.12.
* gnu/packages/golang-web.scm (go-github-com-multiformats-go-multiaddr-0.12): New variable. Change-Id: I27e70dc3a393bd72f2f43fbc2607ea105caccaef Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/golang-web.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 723af582b7..bb0cacb51e 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -56,6 +56,7 @@
#:use-module (gnu packages golang-compression)
#:use-module (gnu packages golang-crypto)
#:use-module (gnu packages golang-xyz)
+ #:use-module (gnu packages ipfs)
#:use-module (gnu packages tls)
#:use-module (gnu packages web))
@@ -1341,6 +1342,32 @@ following:
@end itemize")
(license license:expat)))
+;; It's for the Kubo update; remove it when it is no longer needed.
+(define-public go-github-com-multiformats-go-multiaddr-0.12
+ (package
+ (inherit go-github-com-multiformats-go-multiaddr)
+ (name "go-github-com-multiformats-go-multiaddr")
+ (version "0.12.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/multiformats/go-multiaddr")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rn02yn7494r7ayn585bbsddprbn8wdccxs4n2k5dmll4dyd39mp"))))
+ (arguments
+ (list
+ #:go go-1.21
+ #:import-path "github.com/multiformats/go-multiaddr"))
+ (native-inputs (list go-github-com-stretchr-testify))
+ (propagated-inputs (list go-github-com-ipfs-go-cid
+ go-github-com-multiformats-go-multibase
+ go-github-com-multiformats-go-varint
+ go-github-com-multiformats-go-multihash-0.2.3
+ go-golang-org-x-exp-2023))))
+
(define-public go-github-com-multiformats-go-multiaddr-net
;; This commit is from <2018-10-01> and associated with GX package manager,
;; since that time the project has changed versing stile and GX is dropped.