summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:26:43 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:50 +0200
commit88205e3e04f6772a64ba49ff25527e3b7a3afebb (patch)
tree3ca2c39db89623509dfa64b61ad8e4be4efe6741
parentd033c4b77afec5c0c592e88a48171fa4fd6471af (diff)
gnu: Add texlive-texloganalyser.
* gnu/packages/tex.scm (texlive-texloganalyser): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 650417f265..b888161a0c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6480,6 +6480,27 @@ replace your (LaTeX) compilation command with @samp{texliveonfly.py
file.tex}.")
(license license:gpl3)))
+(define-public texlive-texloganalyser
+ (package
+ (name "texlive-texloganalyser")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/support/texloganalyser/"
+ "scripts/texloganalyser/")
+ (base32
+ "0qlrpqwfyakhh163ckznw5z8jwm5frp3krpi7fxnf9pz03c7shhr")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "texloganalyser")))
+ (inputs (list perl))
+ (home-page "https://ctan.org/pkg/texloganalyser")
+ (synopsis "Analyse TeX logs")
+ (description
+ "This Perl script allows the user to extract (and display) elements of
+the log file.")
+ (license license:bsd-2)))
+
(define-public texlive-ticollege
(package
(name "texlive-ticollege")