summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:26:32 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:50 +0200
commitd033c4b77afec5c0c592e88a48171fa4fd6471af (patch)
treef9d1bf14b8440d5a3400d89b0e5e3762da4a01f0
parentd87cb08dd3594bcf4bad5a0d3579fcbd90f99b1c (diff)
gnu: Add texlive-texliveonfly.
* gnu/packages/tex.scm (texlive-texliveonfly): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b03c3417e5..650417f265 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6457,6 +6457,29 @@ from a TeX run, attempting to show only those messages which probably deserve
some change in the source. The TeX invocation itself need not change.")
(license license:public-domain)))
+(define-public texlive-texliveonfly
+ (package
+ (name "texlive-texliveonfly")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/support/texliveonfly/"
+ "scripts/texliveonfly/")
+ (base32
+ "15nrgkh9wkaccbyd8jgcyw5xjjhqj3jyy3spbfd679fywq14l8c2")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "texliveonfly.py")))
+ (inputs (list python))
+ (home-page "https://ctan.org/pkg/texliveonfly")
+ (synopsis "On-the-fly download of missing TeX live packages")
+ (description
+ "The package provides a script that performs on the fly downloads of
+missing packages, while a document is being compiled. To use the script,
+replace your (LaTeX) compilation command with @samp{texliveonfly.py
+file.tex}.")
+ (license license:gpl3)))
+
(define-public texlive-ticollege
(package
(name "texlive-ticollege")