summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-29 14:05:10 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-29 14:21:00 +0000
commit8ed9ce9d0070b854f0aadc6626e624ba2156c112 (patch)
tree905d8900e8b73575563c897760ab70b19ca74eea
parent9358929873d235e01461a45b8a2a9789fdb6c5f0 (diff)
gnu: go-github-com-danwakefield-fnmatch: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-danwakefield-fnmatch): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. * gnu/packages/mail.scm: Add (gnu packages golang-xyz) module. Change-Id: I2d5d0565f4c758f49032cadfa1dcca7e884a577b
-rw-r--r--gnu/packages/golang-xyz.scm27
-rw-r--r--gnu/packages/golang.scm25
-rw-r--r--gnu/packages/mail.scm1
3 files changed, 28 insertions, 25 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 8e34c34e7b..e1ac32273c 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -784,6 +784,33 @@ of unit files.")))
metrics to Graphite.")
(license license:bsd-2)))
+(define-public go-github-com-danwakefield-fnmatch
+ (let ((commit "cbb64ac3d964b81592e64f957ad53df015803288")
+ (revision "0"))
+ (package
+ (name "go-github-com-danwakefield-fnmatch")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/danwakefield/fnmatch")
+ (commit commit)))
+ (sha256
+ (base32 "0cbf511ppsa6hf59mdl7nbyn2b2n71y0bpkzbmfkdqjhanqh1lqz"))
+ (file-name (git-file-name name version))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/danwakefield/fnmatch"))
+ (home-page "https://github.com/danwakefield/fnmatch")
+ (synopsis "Updated clone of kballards golang fnmatch gist")
+ (description
+ "This package provides string-matching based on BSD fnmatch.3. It is an
+updated clone of kballards golang fnmatch
+gist (https://gist.github.com/kballard/272720).")
+ (license license:bsd-2))))
+
(define-public go-github-com-dave-jennifer
(package
(name "go-github-com-dave-jennifer")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3a10b8c03c..385da42eda 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6045,31 +6045,6 @@ and aid debugging.")
a cron spec parser and job runner.")
(license license:expat)))
-(define-public go-github-com-danwakefield-fnmatch
- (let ((commit "cbb64ac3d964b81592e64f957ad53df015803288")
- (revision "0"))
- (package
- (name "go-github-com-danwakefield-fnmatch")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/danwakefield/fnmatch")
- (commit commit)))
- (sha256
- (base32
- "0cbf511ppsa6hf59mdl7nbyn2b2n71y0bpkzbmfkdqjhanqh1lqz"))
- (file-name (git-file-name name version))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/danwakefield/fnmatch"))
- (home-page "https://github.com/danwakefield/fnmatch")
- (synopsis "Updated clone of kballards golang fnmatch gist")
- (description "This package provides an updated clone of kballards golang
-fnmatch gist (https://gist.github.com/kballard/272720).")
- (license license:bsd-2))))
-
(define-public go-github-com-ddevault-go-libvterm
(let ((commit "b7d861da381071e5d3701e428528d1bfe276e78f")
(revision "0"))
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 23c78a6db5..96a1e3b199 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -113,6 +113,7 @@
#:use-module (gnu packages golang-check)
#:use-module (gnu packages golang-crypto)
#:use-module (gnu packages golang-web)
+ #:use-module (gnu packages golang-xyz)
#:use-module (gnu packages groff)
#:use-module (gnu packages gsasl)
#:use-module (gnu packages gtk)