summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-23 09:20:31 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-27 23:08:18 +0000
commit90ec785f21e6fa0ffcd2ed093c417f160c0302c8 (patch)
tree11be4cc12c71eff03e0ad49e557f57d3e0958303
parentcf5c8c49021f7a4280d9e9dd99cacb50a0106742 (diff)
gnu: clipman: Refresh package style.
* gnu/packages/xdisorg.scm (clipman): Adjust indentation. [arguments] <#:phases>: Rename 'patch to 'patch-wl-copy-path phase to reflect the purpose. Revert default 'install-license-files phase. [native-inputs]: Remove go-github-com-alecthomas-template and go-github-com-alecthomas-units, they are propagated from go-gopkg-in-alecthomas-kingpin-v2. Change-Id: I5332906c126904ced595aa322be5f933c305c5f7
-rw-r--r--gnu/packages/xdisorg.scm47
1 files changed, 24 insertions, 23 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 8d3fd446ee..ace1daca38 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -3224,31 +3224,32 @@ After selection, the clip is put onto the PRIMARY and CLIPBOARD X selections.")
(package
(name "clipman")
(version "1.6.2")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/chmouel/clipman")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256 (base32
- "033l2hy46r2zjy8dllcmkjxidhnqac9kfh4wkq9hfvim9imp5a4m"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/chmouel/clipman")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "033l2hy46r2zjy8dllcmkjxidhnqac9kfh4wkq9hfvim9imp5a4m"))))
(build-system go-build-system)
(arguments
- (list #:import-path "github.com/yory8/clipman"
- #:install-source? #f
- #:phases #~(modify-phases %standard-phases
- (add-before 'build 'patch
- (lambda _
- (substitute* "src/github.com/yory8/clipman/main.go"
- (("\"wl-copy\"")
- (string-append "\"" (which "wl-copy") "\"")))))
- (delete 'install-license-files))))
- (native-inputs (list go-github-com-alecthomas-template
- go-github-com-alecthomas-units))
- (inputs (list go-github-com-kballard-go-shellquote
- go-gopkg-in-alecthomas-kingpin-v2
- libnotify
- wl-clipboard))
+ (list
+ #:import-path "github.com/yory8/clipman"
+ #:install-source? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'patch-wl-copy-path
+ (lambda _
+ (substitute* "src/github.com/yory8/clipman/main.go"
+ (("\"wl-copy\"")
+ (string-append "\"" (which "wl-copy") "\""))))))))
+ (inputs
+ (list go-github-com-kballard-go-shellquote
+ go-gopkg-in-alecthomas-kingpin-v2
+ libnotify
+ wl-clipboard))
(synopsis "Basic clipboard manager with support for persisting copy buffers")
(description
"A clipboard manager for Wayland that relies on an external selector,