summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:21:24 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:44 +0200
commitbb5263af7c3fc597da4b88ca5cef783403681921 (patch)
tree5bd7cd02fc454c32ad90a9ae0c58c846e3ed772a
parent4061203dd560fc670b2dd9518e05116c57f3ce0e (diff)
gnu: Add texlive-pkfix-helper.
* gnu/packages/tex.scm (texlive-pkfix-helper): New variable.
-rw-r--r--gnu/packages/tex.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f54aae9029..4cda7c7159 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3169,6 +3169,37 @@ PostScript files, generated by not too old dvips, and replaces them by type
1 versions of the fonts, if possible.")
(license license:lppl1.3+)))
+(define-public texlive-pkfix-helper
+ (package
+ (name "texlive-pkfix-helper")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/pkfix-helper.1"
+ "doc/man/man1/pkfix-helper.man1.pdf"
+ "doc/support/pkfix-helper/"
+ "scripts/pkfix-helper/")
+ (base32
+ "0vq52g65an1v9g0kdhsy0xpsf1hj69gl4cr5aq1m816i8ahhzxxy")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "pkfix-helper")))
+ (inputs (list perl))
+ (home-page "https://ctan.org/pkg/pkfix-helper")
+ (synopsis "Make PostScript files accessible to pkfix")
+ (description
+ "Pkfix is a useful utility for replacing resolution-dependent bitmapped
+fonts in a dvips-produced PostScript file with the corresponding
+resolution-independent vector fonts. Unfortunately, @command{pkfix} needs to
+parse certain PostScript comments that appear only in files produced by dvips
+versions later than 5.58 (circa 1996); it fails to work on PostScript files
+produced by older versions of dvips. Pkfix-helper is a program that attempts
+to insert newer-dvips comments into an older-dvips PostScript file, thereby
+making the file suitable for processing by @command{pkfix}.
+@command{pkfix-helper} can sometimes process documents fully autonomously but
+does require the user to verify and, if needed, correct its decisions.")
+ (license license:lppl1.3c)))
+
(define-public texlive-tex-ini-files
(package
(name "texlive-tex-ini-files")