summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-28 23:39:48 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-29 14:20:59 +0000
commitbcfbb05fdb0731166a9b49aff5be32025ba92695 (patch)
tree4dfefe059a1f94ac4608075a2cef7734cdaf5d95
parentdde7bb4f74d13ab9412514bb936189c2176d8438 (diff)
gnu: Add go-github-com-logrusorgru-aurora-v3.
* gnu/packages/golang-xyz.scm (go-github-com-logrusorgru-aurora-v3): New variable. Change-Id: Iec34c29b6785ada697ad9cded7060a221d60abc9
-rw-r--r--gnu/packages/golang-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 7852c6b8ed..291389a893 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1386,6 +1386,25 @@ database/sql package.")
Printf/Sprintf etc.")
(license license:unlicense)))
+(define-public go-github-com-logrusorgru-aurora-v3
+ (package
+ (inherit go-github-com-logrusorgru-aurora)
+ (name "go-github-com-logrusorgru-aurora-v3")
+ (version "3.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/logrusorgru/aurora")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "0z7cgj8gl69271d0ag4f4yjbsvbrnfibc96cs01spqf5krv2rzjc"))
+ (file-name (git-file-name name version))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/logrusorgru/aurora/v3"))))
+
(define-public go-github-com-kballard-go-shellquote
;; No release, see <https://github.com/kballard/go-shellquote/issues/13>.
(let ((commit "95032a82bc518f77982ea72343cc1ade730072f0")