summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2015-12-27 19:50:57 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-01-17 22:37:04 +0200
commitc18f6368239de2c4be6560a4e0fa68a36c45374d (patch)
treeb6256197516300b1fe32d13d4cfff2c67aa4acb1
parente1ba074999747c8416355322361e2a6d158c6228 (diff)
gnu: Add python-urllib3.
* gnu/packages/python.scm (python-urllib3, python2-urllib3): New variables.
-rw-r--r--gnu/packages/python.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 13ad87fc8d..a1757a08fc 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7198,3 +7198,39 @@ concurrent.futures package from Python 3.2")
(define-public python2-futures
(package-with-python2 python-futures))
+
+(define-public python-urllib3
+ (package
+ (name "python-urllib3")
+ (version "1.13.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "urllib3" version))
+ (sha256
+ (base32
+ "10rrbr6c6k7j5dvfsyj4b2gsgxg9gggnn708qixf6ll57xqivfkf"))))
+ (build-system python-build-system)
+ (arguments `(#:tests? #f))
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)
+ ;; some packages for tests
+ ("python-nose" ,python-nose)
+ ("python-mock" ,python-mock)
+ ("python-tornado" ,python-tornado)))
+ (propagated-inputs
+ `(;; packages for https security
+ ("python-certifi" ,python-certifi)
+ ("python-ndg-httpsclient" ,python-ndg-httpsclient)
+ ("python-pyasn1" ,python-pyasn1)
+ ("python-pyopenssl" ,python-pyopenssl)))
+ (home-page "http://urllib3.readthedocs.org/")
+ (synopsis "HTTP library with thread-safe connection pooling")
+ (description
+ "Urllib3 supports features left out of urllib and urllib2 libraries. It
+can reuse the same socket connection for multiple requests, it can POST files,
+supports url redirection and retries, and also gzip and deflate decoding.")
+ (license license:expat)))
+
+(define-public python2-urllib3
+ (package-with-python2 python-urllib3))