summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2015-12-27 09:39:51 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-01-17 22:37:04 +0200
commite1ba074999747c8416355322361e2a6d158c6228 (patch)
tree2520444e6b370b53229ce9a301a838dd3c6ccb3b
parent10468636ff823b77f04ae0de03a9f78691a0bbd8 (diff)
gnu: python-wheel: Clarify description.
* gnu/packages/python.scm (python-wheel): Do it.
-rw-r--r--gnu/packages/python.scm42
1 files changed, 23 insertions, 19 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 76bce72352..13ad87fc8d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2119,25 +2119,29 @@ with sensible defaults out of the box.")
(package
(name "python-wheel")
(version "0.26.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "wheel" version))
- (sha256
- (base32
- "032k1ajijbqnv0z0k88bhf75mdimi18fcmm28mss90610lw3bbga"))))
- (build-system python-build-system)
- (native-inputs
- `(("python-setuptools" ,python-setuptools)
- ("python-jsonschema" ,python-jsonschema)
- ("python-pytest-cov" ,python-pytest-cov)))
- (home-page "https://bitbucket.org/pypa/wheel/")
- (synopsis "Built-package format for Python")
- (description
- "A wheel is a ZIP-format archive with a specially formatted filename and the
-.whl extension. It is designed to contain all the files for a PEP 376
-compatible install in a way that is very close to the on-disk format.")
- (license license:expat)))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "wheel" version))
+ (sha256
+ (base32
+ "032k1ajijbqnv0z0k88bhf75mdimi18fcmm28mss90610lw3bbga"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)
+ ("python-jsonschema" ,python-jsonschema)
+ ("python-pytest-cov" ,python-pytest-cov)))
+ (home-page "https://bitbucket.org/pypa/wheel/")
+ (synopsis "Format for built Python packages")
+ (description
+ "A wheel is a ZIP-format archive with a specially formatted filename and
+the @code{.whl} extension. It is designed to contain all the files for a PEP
+376 compatible install in a way that is very close to the on-disk format. Many
+packages will be properly installed with only the @code{Unpack} step and the
+unpacked archive preserves enough information to @code{Spread} (copy data and
+scripts to their final locations) at any later time. Wheel files can be
+installed with a newer @code{pip} or with wheel's own command line utility.")
+ (license license:expat)))
(define-public python2-wheel
(package-with-python2 python-wheel))