summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-22 21:17:34 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-27 21:33:42 +0000
commitd2dcd4c7e1b85392759c966f14c810de4ec233c0 (patch)
tree28cc6c2f5031069dcf515dce31ed57e2780deed6
parent2173e4a12ea7188c402c943b6870348253520da8 (diff)
gnu: go-github-com-alecthomas-template: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-alecthomas-template): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Iffdd88439819c526cd6dd940192bf48995bf76bc
-rw-r--r--gnu/packages/golang-xyz.scm27
-rw-r--r--gnu/packages/golang.scm27
2 files changed, 27 insertions, 27 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 8156cff05e..5f914f28ae 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -201,6 +201,33 @@ structs. The approach is similar to how other marshallers work in Golang,
\"unmarshalling\" an instance of a grammar into a struct.")
(license license:expat)))
+(define-public go-github-com-alecthomas-template
+ (let ((commit "a0175ee3bccc567396460bf5acd36800cb10c49c")
+ (revision "0"))
+ (package
+ (name "go-github-com-alecthomas-template")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alecthomas/template")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0qjgvvh26vk1cyfq9fadyhfgdj36f1iapbmr5xp6zqipldz8ffxj"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/alecthomas/template"))
+ (home-page "https://github.com/alecthomas/template")
+ (synopsis "Fork of Go's text/template adding newline elision")
+ (description
+ "This is a fork of Go 1.4's text/template package with one addition: a
+backslash immediately after a closing delimiter will delete all subsequent
+newlines until a non-newline.")
+ (license license:bsd-3))))
+
(define-public go-github-com-anmitsu-go-shlex
(package
(name "go-github-com-anmitsu-go-shlex")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 062985c0ce..18f0e6f7ac 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9609,33 +9609,6 @@ GNU/Linux, this is a proxy for the @command{xdg-open} command.")
(home-page "https://github.com/skratchdot/open-golang")
(license license:expat))))
-(define-public go-github-com-alecthomas-template
- (let ((commit "a0175ee3bccc567396460bf5acd36800cb10c49c")
- (revision "0"))
- (package
- (name "go-github-com-alecthomas-template")
- (version (git-version "0.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/alecthomas/template")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0qjgvvh26vk1cyfq9fadyhfgdj36f1iapbmr5xp6zqipldz8ffxj"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/alecthomas/template"
- #:phases %standard-phases))
- (synopsis "Fork of Go's text/template adding newline elision")
- (description
- "This is a fork of Go 1.4's text/template package with one addition: a
-backslash immediately after a closing delimiter will delete all subsequent
-newlines until a non-newline.")
- (home-page "https://github.com/alecthomas/template")
- (license license:bsd-3))))
-
(define-public go-github-com-alecthomas-units
(let ((commit "2efee857e7cfd4f3d0138cc3cbb1b4966962b93a")
(revision "0"))